minimum requirements for maximum return

To get the best possible illumy experience, you’ll want to make sure your browser, desktop/laptop operating system (OS), and mobile OS meet the minimum requirements for illumy.

web browsers

If you’re not sure which browser version you’re using, check it here.

Web Browser Version
Google Chrome Version 51 and up
Mozilla Firefox Version 52 and up
Apple Safari Version 9 and up*
Microsoft Edge Version 41 and up*

*Voice and video calling using WebRTC aren’t supported in these browsers (yet).

mobile operating systems

Find your iOS version by going to Settings > General > About, and look for “Software Version” (near the top).
Check your Android OS version by going to Settings > About Phone (or About Device) > Android Version.

Mobile OS Version
Apple iOS iOS 13.0 and up (iPhone 6s or SE and later) 
Android OS Android 7.0 (Nougat) and up

desktop/laptop operating systems

Microsoft’s website has easy-to-use instructions to find which version of Windows you’re using.
To see which Mac OS version you’re using, click the Apple logo in the upper left of your computer screen, and select “About This Mac.”

Operating System Version
Microsoft Windows Windows 7 and up
Apple Macintosh Mac OS X 10.9 (Mavericks) and up

unsupported browsers & operating systems

illumy is initially supporting the most commonly used browsers and operating systems. Delivering a great user experience requires extensive testing and certification of each environment. We’re working hard to bring illumy to even more awesome people.

If you don’t see your device or OS listed, check this page again in the future. We’re continually developing, testing, and working with browser and OS vendors to add to this list. If you’re not sure if illumy works with your setup, try it out—and let us know how it goes: support@illumy.com